domingo, 8 de junio de 2014

El cuadro de Punnett para un monohíbrido con dos alelos en Excel, ejemplo analítico, parte 1 resolviendo el cuadro de Punnett

El cuadro de Punnett para un monohíbrido con dos alelos en Excel, ejemplo analítico, parte 1 resolviendo el cuadro de Punnett

Emplearemos el cuadro de Punnett, el objetivo es obtener los genotipos posibles que corresponde a la parte analítica, y posteriormente sus frecuencias, lo cual corresponde a la parte numérica.

La función que nos permitirá realizar el cálculo se denomina &, por ejemplo:

Esto se logra con la siguiente fórmula:

El problema es que esta fórmula no nos va a organizar los alelos para poder igualar los fenotipos posteriormente, es decir, al arrastrarla queda del siguiente modo

Para evitar este problema se debe escribir un condicional =SI(A2<B1;A2&B1;SI(A2>B1;B1&A2; A2&B1))

Posteriormente se lo arrastra uno por uno y se corrigen las celdas, si se hace bien, el resultado es el siguiente


Nota, esto funciona solo cuando tenemos una designación numérica de los alelos, esto se debe a que la función mayor que (<) no diferencia entre mayúscula y minúscula.

No hay comentarios:

Publicar un comentario